Если нужно переименовать номенклатуру в 1С УТ 11

Было много позиций «МАСЛО ДЛЯ …», «МАСЛО МОТОРНОЕ …», а хотелось бы получить нормальное название «Масло для …» и «Масло моторное …»

Тогда понадобилось сделать очень простую обработку:

&НаКлиенте
Процедура Команда1(Команда)
 Команда1НаСервере();
КонецПроцедуры

&НаСервере
Процедура Команда1НаСервере()
 Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.ЭтоГруппа = ЛОЖЬ
| И Номенклатура.Наименование ПОДОБНО &Наименование
| И Номенклатура.НаименованиеПолное ПОДОБНО &Наименование";
Запрос.УстановитьПараметр("Наименование", "%" + ЧтоМеняем + "%");
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
 Об = Выборка.Ссылка.ПолучитьОбъект();
 Об.Наименование = СтрЗаменить(Об.Наименование, ЧтоМеняем, НаЧтоМеняем);
 Об.НаименованиеПолное = СтрЗаменить(Об.НаименованиеПолное, ЧтоМеняем, НаЧтоМеняем);
 Об.Записать();
 сообщить(Об.Наименование);
КонецЦикла;

КонецПроцедуры

Сама обработка тут

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *